Issue with PHPList

One of our clients installed PHPList on his domain and receives error message while sending message through PHPList as shown below:
Warning: open_basedir restrictions are in effect, which may be the cause of the next warning
Warning: The attachment repository does not exist or is not writable

phplist

To overcome the above issue, one may need to edit the config.php file of PHPlist and need to make changes as mentioned below:

Default:
define(“ALLOW_ATTACHMENTS”,2);
Changes:
define(“ALLOW_ATTACHMENTS”,0);

After making the changes as mentioned above the issue gets resolved. However, he reported us the another issue that he cannot view full page and provided us the following screen capture which is shown below:

Phplist Send Message

Open thorough investigation we have found that it is the bug of PHPList and to overcome this issue one may need to edit the file Send_Core.php which is located inside the administrator folder and need to make the changes as mentioned below:

On lines 1023 and 1024 in send_core.php file you will find:

// value=”‘.htmlentities($subject,ENT_QUOTES,’UTF-8’).'” size=40></td></tr> –> previous code in line 1032
// value=”‘.htmlentities($from,ENT_QUOTES,’UTF-8’).'” size=40> –> previous code in line 1038
On line 1034 and 1040 in the same file you will find:
//value=”‘.htmlentities(iconv(‘ISO-8859-1′,’UTF-8′,$subject),ENT_QUOTES,’UTF-8’).'” size=40>
value=”‘.htmlentities(iconv(‘ISO-8859-1′,’UTF-8′,$from),ENT_QUOTES,’UTF-8’).'” size=40>

Now, need to replace 1034 with the contents of 1023 without the comment, and replace 1040 with 1024 without the comment and the issue get resolved as shown in below mentioned screen capture:

phplist send message

(Visited 23 times, 2 visits today)

Leave a Reply

Your email address will not be published. Required fields are marked *

AlphaOmega Captcha Classica  –  Enter Security Code
     
 

Sign up for a News Letter Click here to sign up