Problem Statement

Recently one of our customer faced strange issue wherein nopCommerce website home page was redirecting to login?ReturnUrl=%2f.

Solution

After some investigation, we assigned necessary permissions to web user of this website and NETWORK SERVICE.
Additionally, we enabled 32 bit application option for the application pool of nopCommerce website.
Following are the steps:
  1. Open IIS manager.
  2. Locate the application Pool used by the website/application in question.
  3. Right click on the application pool name, advanced settings.

    enable-32-bit-application-IIS.png

  4. Enable 32 Bit applications option to TRUE.